JDK-8177751 : Update FX implementation to prepare for renaming of Module and Layer classes
  • Type: Bug
  • Component: javafx
  • Sub-Component: other
  • Affected Version: 9
  • Priority: P2
  • Status: Resolved
  • Resolution: Fixed
  • Submitted: 2017-03-28
  • Updated: 2017-04-06
  • Resolved: 2017-03-29
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
JDK 9
9Fixed
Related Reports
Relates :  
Relates :  
Relates :  
Description
Update FX implementation to prepare for the proposed change for #MoveModuleAndLayerClasses (JSR 376 issue) [1][2] to move Module and Layer classes from java.lang.reflect package to java.lang.

java.lang.reflect.Module -> java.lang.Module
java.lang.reflect.Layer -> java.lang.ModuleLayer

[1] http://openjdk.java.net/projects/jigsaw/spec/issues/
[2] http://mail.openjdk.java.net/pipermail/jpms-spec-observers/2017-March/000843.html
Comments
http://hg.openjdk.java.net/openjfx/9-dev/rt/rev/98e76c78f04f 8177751: Update FX implementation to prepare for renaming of Module and Layer classes Reviewed-by: jgiles, mchung, ddhill, vadim
29-03-2017

+1
29-03-2017

+1 In any case, the javadoc will be reverted to the previous version once the transition is over.
29-03-2017

For anyone hung up on the javadoc changes here is what I intend to push http://cr.openjdk.java.net/~prr/8177751.1/index.html
29-03-2017

+1
29-03-2017

Fix request approved.
29-03-2017

This is most definitely very temporary and so does not matter (much) FWIW I don't think the wording ever read well. Some of the extra is because of the syntax difference and I can edit this before pushing but as I noted this will all get reverted later and hopefully improved so it reads better whether reading javadoc source or generated javadoc.
29-03-2017

The javadoc changes are a little unclear to me. In particular: 1) Application changes two instances of '{@link Module#isExported(String,Module) exported}' to instead be '{@code Module.isExported(String,Module)} exported'. From a grammatical perspective, does this read correctly? The output will resemble the following: 'and the containing package must be Module.isExported(String,Module) exported to the javafx.graphics module.' I don't fully understand what the 'Module.isExported(String,Module) text is supposed to mean to the reader? 2) Conversely, in FXML, the same @link -> @code conversion takes place, but the # is not changed to be a period. So, this feels inconsistent, but it also feels like there is still some readability issue here: "and the module containing that class Module#isExported(String,Module) exports the containing package to the javafx.fxml module.'
29-03-2017

Looks good to me.
28-03-2017

webrev: http://cr.openjdk.java.net/~prr/8177751/ Fix has been both built and tested against jdk9 + jake forests.
28-03-2017