JDK-8023082 : There are much more JVM instances than before for html containing multiple applets.
  • Type: Bug
  • Component: deploy
  • Sub-Component: plugin
  • Affected Version: 7u40,7u45,8,9
  • Priority: P4
  • Status: Resolved
  • Resolution: Duplicate
  • Submitted: 2013-08-15
  • Updated: 2015-01-05
  • Resolved: 2015-01-05
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
Related Reports
Duplicate :  
Relates :  
Steps to reproduce:
1. Install the 7u40-b39 promoted build.
2. turn java console on
3. Access page http://kgb.us.oracle.com:8080/LiveConnectTest/html/testMultipleApp.html
4. Accept the unsigend code sec warning dialog
5. If you see a lot java console showing up, then the issue is reproduced.

with previous jre release, looks like there's only one jvm instance there.

There is no functional regression, so mark it as p4.

This is a duplicate for JDK-8023095. Tried with 8u40-b20 and only 2 instances are created. This is expected behavior since one of criteria to spawn a new JVM instance is the number of threads exceeds 50 (this default could be changed by setting deployment.system.maxAppletThreadCount in deployment.properties) and every applet creates at least 3 new threads. Thus, no more then 16 applets could coexist in the same JVM. The tests creates 27 applets that results in 2 JVM instances are created.

Affected tests: LiveConnectTest::testMultipleApp LiveConnectTest::testMultipleAppOE LiveConnectKFLTest::testMultipleApp LiveConnectKFLTest::testMultipleAppOE

Ok, then it seems like a x86 problem - because I tried win7 64 bit for IE/FF/Chrome - and it works fine, only one jvm is created.

Could you please try 7u45-nightly-#253 on Windows 7-x86/Chrome? Just open the link, and wait there for like 1 ~ 2 minutes, you should see a lot of java console dialogs eventually. I just reproduced on my local vm.

CNR for latest 7u45 and 8.

I was not able to reproduce this issue for latest 8, seems like it's already fixed, and the problem was that we could not attach to existing JVM.