JDK-8016005 : Remote debugging for applets in a browser is no longer working
  • Type: Bug
  • Component: deploy
  • Sub-Component: plugin
  • Affected Version: 7u21,7u40
  • Priority: P3
  • Status: Resolved
  • Resolution: Fixed
  • OS: generic
  • CPU: x86
  • Submitted: 2013-06-05
  • Updated: 2015-12-21
  • Resolved: 2013-07-02
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
7u40Fixed 8 b97Fixed
Related Reports
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Relates :  
Relates :  
Remote debugging (for applets in a browser) is no longer working as it did work for 7u15 before, i.e. unable to connect to a JVM with Eclipse since 7u21 and 7u40 latest build.

Normally using the following JRE runtime parameters in the Java control panel allows us to connect remotely to debug the JRE:

��         -Djava.compiler=NONE -Xnoagent -Xdebug -Xrunjdwp:transport=dt_socket,address=8000,server=y,suspend=n

This worked in JRE 7u15, and has not worked since then. The only difference in tests is the JRE version, same browser, eclipse and applet.

one post of someone else having the same issue, is this something that has changed as part of the security as well? How can we once again debug applets using Eclipse?

Here is the post of someone reporting a similar issue.

��         https://forums.oracle.com/forums/thread.jspa?threadID=2528343
justification: serious regression since 7u21. developer cannot debug applets with debugger.

SQE-OK to get the issue fixed for 7u40.

Duplicates JDK-8016154

Duplicates JDK-8015681

Windows 7 64 bit, but using the 32 bit JREs in all cases.