JDK-6469064 : RFE: Support SCIM
  • Type: Enhancement
  • Component: client-libs
  • Sub-Component: java.awt:i18n
  • Affected Version: 6
  • Priority: P4
  • Status: Closed
  • Resolution: Future Project
  • OS: linux_2.6
  • CPU: x86
  • Submitted: 2006-09-11
  • Updated: 2010-08-05
  • Resolved: 2007-08-08
Related Reports
Relates :  
Relates :  
Relates :  
Relates :  
Steps to reproduce:
unzip attached test program [JavaApplication2.zip].
% cd dist
% java -jar JavaApplication2.jar
open dialog
input something (ex, nihonn + SPACE)
close dialog
open dialog
input something (ex, nihonn + SPACE)
=> you should be able to see uncommitted texts disappear.

Tested on Fedora Core 5 in Japanese locale + jdk1.6.0 b98/jdk1.5.0_07
# uname -a
Linux bombay.japan.sun.com 2.6.15-1.2054_FC5 #1 Tue Mar 14 15:48:33 EST 2006 i686 i686 i386 GNU/Linux
# rpm -qa |egrep "scim|anthy"
In SUSE Enterprise Linux 10, Japanese seems work well but I could see the problem in zh_CN locale. So this seems still a problem for Asian locales support in this platform.

EVALUATION This RFE (Request For Enhancement) is for a new input method adapter that supports SCIM directly, not through the SCIM-XIM bridge. Please use 6616695 for getting around SCIM-XIM bridge bugs.

EVALUATION Submitter also tried on the SuSE 10 with zh_CN.utf8 locale to successfully reproduce the problem. According to the skim handbook,ch3 "Using skim" (http://scim.sourceforge.net/skim/doc/user/en/#using-skim) The supported locales by scim-lib do not include utf8 locales. In fact, when I switched the locale from zh_CN.utf8 to zh_CN, the test application didn't show the problem. To use SCIM with the locale with utf8 encoding, skim is recommended to use. On my SuSE 10, the skim packages were installed and that seems to be the reason it works on my SuSE but not on the submitter's. (Note: The above doc is dated in October 2004, 2 years and 4 month old)

EVALUATION Evaluated with SuSE Linux ES 10 in ja_JP.utf8. Java version: JDK7 b07 I tried the following steps as shown in the description: % cd dist % java -jar "JavaApplication2.jar" open dialog CTRL+SPACE input something (ex, nihonn + SPACE) close dialog open dialog CTRL+SPACE input something (ex, nihonn + SPACE) I see the uncommitted texts underlined waiting to be comitted. They're not disappearing. For SCIM information: % rpm -qa | egrep "scim|anthy" scim-1.4.4-23.4 scim-hangul-skim- scim-qtimm-0.9.4-15.2 scim-tables-skim-0.5.6-17.2 scim-chewing-0.2.1-16.2 scim-tables-0.5.6-17.2 scim-tables-ja-0.5.6-17.2 scim-input-pad-0.1.1-15.2 anthy-7307-14.2 scim-hangul- scim-tables-ko-0.5.6-17.2 scim-pinyin-skim- scim-pinyin- scim-tables-zh-0.5.6-17.2 scim-tables-additional-0.5.6-17.2 scim-m17n-0.2.0-15.2 scim-anthy-0.8.0-14.2 Looks like SCIM is supported. Is it possible to update the SCIM? Please let me know if you see differently. I'm marking this as Incomplete requesting more information. Thanks.

EVALUATION It's known that the SCIM-XIM bridge has some problems. Java may need to support SCIM directly rather than through XIM.