JDK-8027686 : Fail to install on MacOS 10.10
  • Type: Bug
  • Component: install
  • Affected Version: 7u45
  • Priority: P1
  • Status: Closed
  • Resolution: Fixed
  • OS: os_x
  • Submitted: 2013-11-01
  • Updated: 2015-08-07
  • Resolved: 2014-05-12
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
JDK 7 JDK 8 JDK 9
7u71Fixed 8u20 b17Fixed 9Fixed
Related Reports
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Description
Java installer does not recognize 10.10 as a later version than 10.7. See attachment for a screen shot. 


Comments
SQE is ok to take the fix in CPU14_04.
2014-06-26

Verified with 8u20 b19 per dev instruction
2014-06-23

At least now: - the crucible review request is not completed. - JDK8u25 b01 not yet tested by SQE. - SQE doesn't have Mac OS 10.10 on board to verify the fix. Taking into account this is not a show stopper for CPU14_03 SQE is NOT OK to take it in CPU14_03.
2014-06-08

Confirmed the installer for JDK 8u20 b17 downloaded from jdk8.java.net does indeed install on OS X 10.10 Developer Preview
2014-06-05

8u20_b017 which has the fix was pushed to https://jdk8.java.net/download.html
2014-06-04

Verified with 8u20 PIT b17
2014-05-28

JRE/JDK packages comparing supported version and OS ProductVersion strings, should use installer javascript function compareVersions (https://developer.apple.com/library/mac/documentation/DeveloperTools/Reference/InstallerJavaScriptRef/system/system.html#//apple_ref/javascript/instm/System/compareVersions)
2014-05-08

Marvin: do you have a Mac 10.10 machine that we can test the fix with?
2014-04-03

More like two years... the latest on ADC is 10.9.1, there are no developer accessible copies of anything later than that.
2014-01-06

Root cause of this is probably factoring in sig figure of $min version. 10.10 is ~1 year from release. How can we get an advance copy/login cred to test this?
2013-11-01