JDK-8011043 : Warn about use of 1.5 and earlier source and target values
  • Type: Enhancement
  • Component: tools
  • Sub-Component: javac
  • Affected Version: 8
  • Priority: P3
  • Status: Resolved
  • Resolution: Fixed
  • OS: generic
  • CPU: generic
  • Submitted: 2013-03-29
  • Updated: 2017-05-17
  • Resolved: 2013-08-20
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availabitlity Release.

To download the current JDK release, click here.
JDK 8
8 b105Fixed
Related Reports
Relates :  
Relates :  
Relates :  
Description
The javac tool supports source and target options whose origin stretches back into the early mists of the Java platform. As of JDK 8, using options for source and target values corresponding to JDK 5 are earlier should generate a warning as support for those options will be removed in a future release.
Comments
See: JEP 182: Policy for Retiring javac -source and -target Options http://openjdk.java.net/jeps/182
2013-04-09