JDK-6384805 : XSLTC ignores XML namespace, when nodeset is created within a template
  • Type: Bug
  • Component: xml
  • Sub-Component: javax.xml.transform
  • Affected Version: 5.0u6
  • Priority: P2
  • Status: Closed
  • Resolution: Fixed
  • OS: windows_xp
  • CPU: x86
  • Submitted: 2006-02-13
  • Updated: 2012-04-25
  • Resolved: 2007-07-13
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availabitlity Release.

To download the current JDK release, click here.
Other JDK 6 JDK 7
1.4.0 1.4Fixed 6u18Fixed 7Fixed
Related Reports
Relates :  
Relates :  
Relates :  
XSLTC ignores XML namespace, when nodeset is created within a template.
Example attached.

EVALUATION The issue was fixed on 01/12/2007. The fix is available from the jaxp project on java.net. (jaxp.dev.java.net).

EVALUATION Joe has tried the latest test case and was able to reproduce the problem. Changing status to 3.

EVALUATION Like Sunitha, I'm unable to reproduce this problem. I've tried the source provided in the attachments (with some minor changes to find the XSL and XML files) but the result I get is the same in the so-called "bad" and "good" cases. I'll attach my output for reference purposes. I've tried Tiger and Mustang with the same result. Either the test case is invalid or the bug has been fixed already. Since two engineers have looked at this already, I'm going to close it as not-a-bug until a working test case is provided.

EVALUATION Scenario Background: The scenario, I had been working with, is about transforming StarOffice / OpenOffice.org documents. These documents can occur in one XML file (e.g. a suffix as fsxw for flat writer) or in multiple XML files (ie. content.xml, styles.xml, settings.xml, meta.xml), which are zipped to a single document and loaded by a JAR URL (suffix the same without 'f'). Furthermore, there had been a problem with a DTD referenz in those files, which was a fake reference, the DTD did not exists and which was loaded from disc (if available), but only once and being cached.

EVALUATION I reproduced your test example and I understand the confusion now. There is obviously a side effect occuring in the scenario I used. Reproduced the problem under JDK 1.5b06 and attached test scenario.

EVALUATION This bug is reproducible neither with Java 1.5.0_04 nor with Mustang b78. Could you let us know, which version of JDK is being used?

EVALUATION test case appears to be valid so bug is being accepted.