JDK-8293117 introduced a suite of functions for atomic bit manipulation, with names "fetch_then_OP" and "OP_then_fetch" for the various OPs (and/or/xor). This naming convention was chosen in part because "fetch_and_and" and similar names that would be consistent with the existing "add" variants seemed odd and confusing.
It would be better to have consistent naming, so we should make these name changes:
- "fetch_and_add" => "fetch_then_add"
- "add_and_fetch" => "add_then_fetch"
Note that there are currently no uses of "add_and_fetch" outside the implementation of Atomic. Also note that we don't currently have subtraction variants of either.