JDK-8213112 : Add the 'process' method to Stream class
  • Type: Enhancement
  • Component: core-libs
  • Sub-Component: java.util.stream
  • Affected Version: 12
  • Priority: P4
  • Status: Closed
  • Resolution: Duplicate
  • Submitted: 2018-10-15
  • Updated: 2018-10-30
  • Resolved: 2018-10-30
Related Reports
Duplicate :  
Description
A DESCRIPTION OF THE PROBLEM :
Currently, if one needs to skip some stage or provide a group of reused stages one to have to do the following:

Stream<T> s = collection.stream()
     .map(a -> doIt(a, bb))
    .filter(a -> !a.list().isEmpty());
s = useSecuriytFilter(s, session)
return s.collect(Collector.toList());

Or like:

return useSecuriytFilter(collection.stream()
     .map(a -> doIt(a, bb))
    .filter(a -> !a.list().isEmpty())
    , session);
    .collect(Collector.toList());

In both cases, readability is of code is not high, as fluent sequence of actions is interrupted.

It is suggested to add "process" method to stream like the following signature:

default <R> R process(Function<Stream<T>, R> body) {
   return body.apply(this);
}

Then custom processing could be applied like the following:

return collection.stream()
    .map(a -> doIt(a, bb))
    .filter(a -> !a.list().isEmpty()
    .process( s -> useSecuriytFilter(s, session))
    .collect(Collector.toList());

While semantics is the same, the code structure looks much better. Note this proposed change is not about less typing, but about making local processing looking more local, rather than affecting entire processing pipeline visually. 

The detailed description for motivation is here: 

https://dzone.com/articles/making-java-fluent-api-more-flexible

Some other libraries with processing chain usage pattern like date-time classes in  java.util.time could benefit from this too as common blocks of date arithmetic could be reused in more clean way. 



Comments
openjdk mail thread: http://mail.openjdk.java.net/pipermail/core-libs-dev/2018-October/056307.html
30-10-2018