JDK-8132229 : Unsafe.setRelease/putOrdered* for all types
  • Type: Sub-task
  • Component: core-libs
  • Sub-Component: java.lang.invoke
  • Priority: P4
  • Status: Resolved
  • Resolution: Fixed
  • Submitted: 2015-07-23
  • Updated: 2015-07-27
  • Resolved: 2015-07-27
Description
Unsafe.putOrdered* should also be extended for all basic types.
The additional intrinsification of these methods, if required, is handled with JDK-8132332.

Comments
We will create a parallel hierarchy of Unsafe.setRelease methods for now, make VHs to use it. Unsafe.putOrdered should be deprecated as some point, due to a confusing naming.
27-07-2015

Patch, ready to be reviewed/pushed: http://cr.openjdk.java.net/~shade/8132229/8132229.patch
27-07-2015