JDK-4391042 : Received "not enough space" error when exec'ing a command
  • Type: Bug
  • Component: hotspot
  • Sub-Component: runtime
  • Affected Version: 1.2.2
  • Priority: P2
  • Status: Closed
  • Resolution: Duplicate
  • OS: solaris_8
  • CPU: sparc
  • Submitted: 2000-11-20
  • Updated: 2001-02-09
  • Resolved: 2001-02-09
Related Reports
Duplicate :  
Relates :  
While exec'ing a command line from within Java JDK 1.2.2_06 (native thread,
sunwjit), an I/O exception was returned within a PrivilegedActionException
with the message "Not enough space".

The ulimits of the process were all set to "unlimited" before running
the application.  There is no indication of what resource may have been

Further information:

o The complex function being executed is the launch of a background
  process to add multiple users to Solaris.  The process never gets
  launched by the exec.

o This task worked for about three times before the failure case
  documented here.  Once things failed, the task never worked again,
  even if the SMC 2.0 console was restarted in a new window.

o The test was done on an S8U3 system (build 6) running the installed JRE,
  JDK_1.2.2_06, native threads, sunwjit

The following println statements show the command to be executed
(from within the SMC 2.0 console process) and the traceback of the

VC: command: /usr/sadm/lib/smc/bin/smc -t --trust --hostname sail8-191 --username roo
t --tool com.sun.admin.usermgr.cli.user.UserMgrCli --domain file:/sail8-191/sail8-191
 -J-D"usermgr.Debugging"="ON" -J-D"usermgr.serviceType"="Wbem" -- -i /tmp/muxo_file -
VC: execing command...
VC: PAE exception, msg: Not enough space
java.io.IOException: Not enough space
        at java.lang.UNIXProcess.forkAndExec(Native Method)
        at java.lang.UNIXProcess.<init>(UNIXProcess.java:62)
        at java.lang.Runtime.execInternal(Native Method)
        at java.lang.Runtime.execInternal(Compiled Code)
        at java.lang.Runtime.exec(Compiled Code)
        at java.lang.Runtime.exec(Runtime.java:219)
        at com.sun.management.viperimpl.client.ViperClient$1.run(ViperClient.java:103
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessController.doPrivileged(Compiled Code)
        at com.sun.management.viperimpl.client.ViperClient.execConsole(Compiled Code)
        at com.sun.management.viperimpl.ToolInfrastructureImpl.execConsole(ToolInfras
        at com.sun.admin.usermgr.client.users.AdminMultiUserWiz.doFinish(Compiled Cod
        at com.sun.admin.usermgr.client.users.AdminMultiUserReviewStep.stop(AdminMult
        at com.sun.management.viper.console.gui.wizard.VWizardManager.moveForward(VWi
        at com.sun.management.viper.console.gui.wizard.VWizard.moveForward(Compiled C
        at com.sun.management.viper.console.gui.wizard.VWizard$4.actionPerformed(Comp
iled Code)
        at javax.swing.AbstractButton.fireActionPerformed(Compiled Code)
        at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(Compiled Co
        at javax.swing.DefaultButtonModel.fireActionPerformed(Compiled Code)
        at javax.swing.DefaultButtonModel.setPressed(Compiled Code)
        at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Compiled Code)
        at java.awt.Component.processMouseEvent(Compiled Code)
        at java.awt.Component.processEvent(Compiled Code)
        at java.awt.Container.processEvent(Compiled Code)
        at java.awt.Component.dispatchEventImpl(Compiled Code)
        at java.awt.Container.dispatchEventImpl(Compiled Code)
        at java.awt.Component.dispatchEvent(Compiled Code)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Compiled Code)
        at java.awt.LightweightDispatcher.processMouseEvent(Compiled Code)
        at java.awt.LightweightDispatcher.dispatchEvent(Compiled Code)
        at java.awt.Container.dispatchEventImpl(Compiled Code)
        at java.awt.Window.dispatchEventImpl(Compiled Code)
        at java.awt.Component.dispatchEvent(Compiled Code)
        at java.awt.EventQueue.dispatchEvent(Compiled Code)
        at java.awt.EventDispatchThread.pumpOneEvent(Compiled Code)
        at java.awt.EventDispatchThread.pumpEvents(Compiled Code)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:83)

EVALUATION Could you provide a test app to duplicate this bug. Randy told me that your problem no longer exists. If this is so, could you provide steps you used to fix your problem. gary.collins@East 2000-12-15 Closing this as a dup of bugid 4343908 Java application which calls Runtime.getRuntime().exec() and forks new jvm and then each new JVM has I/O associated with each java.lang.Process and is attached to java.io.InputStream/OutputStream reference. Based on the test code the engineer provided. gary.collins@East 2001-02-09 ###@###.### 2004-06-15: I saw the new update on 2004/6/14 by zopilote2day. Please refer to an update I have made to bug 4343908 on this issue. If you have a test case that reproduces this problem, please send it to your Sun web bugs contact; see 4343908 for more details.