JDK-8214468 : jQuery UI upgrade from 1.11.4 to 1.12.1
  • Type: Bug
  • Component: tools
  • Sub-Component: javadoc(tool)
  • Affected Version: 11,12
  • Priority: P3
  • Status: Resolved
  • Resolution: Fixed
  • Submitted: 2018-11-29
  • Updated: 2020-08-31
  • Resolved: 2018-12-12
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
JDK 11
11.0.4Fixed
Related Reports
Relates :  
Description
Currently javadoc uses jQuery UI of version 1.11.4 and needs to be upgraded to the latest version 1.12.1
Comments
Fix request: Requesting backport to jdk11 because it's part of Oracle's 11.0.4 release. The patch applies cleanly net a conflict in comments of test test/langtools/jdk/javadoc/doclet/testSearch/TestSearch.java. Patch will be tested in nightly regression infrastructure of SAP.
15-05-2019