JDK-8129959 : DebugLogger has unnecessary API methods
  • Type: Enhancement
  • Component: core-libs
  • Sub-Component: jdk.nashorn
  • Affected Version: 9
  • Priority: P4
  • Status: Resolved
  • Resolution: Fixed
  • OS: generic
  • CPU: generic
  • Submitted: 2015-06-26
  • Updated: 2016-01-14
  • Resolved: 2015-06-26
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
8u72Fixed 9 b71Fixed
levelCoarserThan, levelCoarserThanOrEqual, levelFinerThan, levelFinerThanOrEqual, all have confusing names and 3 out of four are unnecessary. We really only need levelFinerThanOrEqual, and since java.util.Logger provides the same predicate under name "isLoggable", we should just rename it as such too and simply delegate to the contained j.u.l.Logger:

    public boolean isLoggable(final Level level) {
        return logger.isLoggable(level);