Nashorn's Node class has both a "TokenType tokenType()" method and a "boolean isTokenType(TokenType)" method, and often we can see expressions of form "node.tokenType() == <tokenType>" that could be consistently replaced with "node.isTokenType(<tokenType>). There's also some weird roundabout usage of "Token.descType(node.getToken())" in places which should simply by "node.tokenType()". No big deal, but API usage consistency is nice to have for clarity.