JDK-8042571 : Cannot run FX applets if Java 7 and 8 are installed and Java 8 is disabled via JCP
  • Type: Bug
  • Component: deploy
  • Affected Version: 8u5
  • Priority: P4
  • Status: Resolved
  • Resolution: Fixed
  • OS: windows
  • Submitted: 2014-05-07
  • Updated: 2014-07-30
  • Resolved: 2014-05-21
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
8u20 b16Fixed 9Fixed
Related Reports
Duplicate :  
Cannot run FX applets in Java 7 and 8 install and Java 8 is disabled via JCP.

Follow steps from https://bugs.openjdk.java.net/browse/JDK-8028644.
1) Install JRE 8u5
2) Install JRE 7u55
3) Disable JRE 8u5 via JCP on Java tab.
4) Run http://download.oracle.com/otndocs/products/javafx/2/samples/Ensemble/index.html

Note: I tried several more FX applets and non of then works.
Browser will give error:
JavaFX application could not launch due to system configuration (show error details). See java.com/javafx for troubleshooting information.

Reproducible on Windows 7 with IE, Firefox and Chrome. Did not tried on other platforms.

Java.com and AWT applets seems to work fine in this configuration.

Targeting for 8u20, since it blocks investigation of JDK-8028644.