JDK-8030223 : [mac OS X] Arrow key input ignored after first press
  • Type: Bug
  • Component: deploy
  • Sub-Component: plugin
  • Affected Version: 7u45,7u51,8
  • Priority: P2
  • Status: Resolved
  • Resolution: Duplicate
  • OS: os_x
  • CPU: x86_64
  • Submitted: 2013-12-16
  • Updated: 2013-12-23
  • Resolved: 2013-12-23
Related Reports
Duplicate :  
Tried with 8b120 and 7u51b. Reproducible in FF and Safari. Reproducible on multiple machines. 
Regression since Apple's Java 6. Not clear if it ever worked with Oracle's Java 7. 

java version "1.8.0-ea"
Java(TM) SE Runtime Environment (build 1.8.0-ea-b120)
Java HotSpot(TM) 64-Bit Server VM (build 25.0-b62, mixed mode)

The arrow key input ignored after first press

Go to  http://www.brainjar.com/java/games/asteroids/
Press S to start game
Press left arrow
Try to press right arrow -  right arrow is ignored. 

Source is available on the same page as the applet. 

dup of https://bugs.openjdk.java.net/browse/JDK-8013948

Justification for deferral: Not a P1 bug, not a regression in JDK 8.

Pretty sure this is a duplicate of JDK-8013948, I will need to verify when I get back to using a Mac