I'd like to propose renaming the following flags -
G1DefaultMinNewGenPercent to G1NewSizePercent,
G1DefaultMaxNewGenPercent to G1MaxNewSizePercent,
G1OldCSetRegionLiveThresholdPercent to G1MixedGCLiveThresholdPercent
The NewSize and MaxNewSize are pretty commonly used flags in Hotspot. Also, while recommending the OldCSetRegionLiveThresholdPercent flag, we will have to provide more background information, instead just talking about MixedGC directly is something that I prefer.