JDK-7127448 : Regression test scripts for policytool need to recognize Mac OS X
  • Type: Bug
  • Component: security-libs
  • Sub-Component: java.security
  • Affected Version: 7u4
  • Priority: P4
  • Status: Closed
  • Resolution: Fixed
  • OS: os_x
  • CPU: x86
  • Submitted: 2012-01-05
  • Updated: 2012-10-06
  • Resolved: 2012-03-29
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
JDK 7
7u4 b11Fixed
Description
Test scripts do not recognize Mac OS X. Add recognition of "Darwin" so that the tests will run on Mac.

Comments
EVALUATION Added "Darwin" to test scripts so that they would recognize Mac OS X. Changeset: dbd828ae28db Author: juh Date: 2012-01-18 16:23 +0000 URL: http://hg.openjdk.java.net/jdk7u/jdk7u-osx/jdk/rev/dbd828ae28db 7127448: Regression test scripts for policytool need to recognize Mac OS X Reviewed-by: michaelm, swingler, weijun
2012-01-20