JDK-6929337 : Java runtime works only as root after update to snv-131
  • Type: Bug
  • Component: install
  • Sub-Component: install
  • Affected Version: 6
  • Priority: P3
  • Status: Closed
  • Resolution: Cannot Reproduce
  • OS: open_solaris
  • CPU: x86
  • Submitted: 2010-02-24
  • Updated: 2011-03-14
  • Resolved: 2011-03-14
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
Related Reports
Relates :  
(If I've filed this bug in the wrong sub-category, please adjust accordingly).

This bug has been opened to get the attention of the Solaris developers.

See also OpenSolaris bug

The description from that bug is included below.
Note that I've added the original bug submitter to the
interest list for this bug. If they are external-to-Sun,
then currently there is no easy way for them to update
the Bugster bug. That's been worked on.

If you need to ask an external-to-Sun original submitter
for further information, please consider adding a comment to
the OpenSolaris bug and get them to place it there.

Java runtime seems to process only when logged as root, symptoms are:

1 - If I access this page http://java.com/en/download/help/testvm.xml as root
the applet runs ok, but accessing from a opensolaris user account the applet
doesn't shows up.

2 - jcontrol access from root allows add, enable and disable java runtime, but
doing it from user account, jcontrol isn't updated.

   This problem was noticed after updating all packages from 2009.06 snv 111 to

There is further commentary in the OpenSolaris bug.

EVALUATION The following was tested Virtual Box running snv 150 as root tried Remote KVM and that worked as root and as regular user There is an attachment with the data for the external web site.

EVALUATION SPoke to submitter and decided to use the lastest release from the following sites. [bcc: to ###@###.### Please send build-related issues to ###@###.### using an appropriate subject heading.] Here are the INTERNAL ONLY Repository ISO images (aka Repo on a DVD) for Build 150. These ISO images contain a snapshot of the repository for the latest available Build 150 of Solaris 11, which can then be used for local mirroring. I have compressed them to save on download time. ***THESE ARE NOT THE LIVE CD ISO IMAGES.*** ** You may burn the split p01 and p02 pieces on regular DVDs. ** Please review the README.sol-11-repo file for proper usage. http://nana.sfbay.sun.com/products/solaris11/150/README.sol-11-repo http://nana.sfbay.sun.com/products/solaris11/150/sol-11-repo-150-full.iso.gz http://nana.sfbay.sun.com/products/solaris11/150/sol-11-repo-150-p01.iso.gz http://nana.sfbay.sun.com/products/solaris11/150/sol-11-repo-150-p02.iso.gz Depending on your browser and system, you may need to use ftp protocol instead of http to pull them over.