JDK-6909759 : using JDK 1.6.0_18-ea does not work with GlassFish v3
  • Type: Bug
  • Component: xml
  • Sub-Component: javax.xml.stream
  • Affected Version: 6
  • Priority: P1
  • Status: Closed
  • Resolution: Fixed
  • OS: generic
  • CPU: generic
  • Submitted: 2009-12-11
  • Updated: 2012-04-24
  • Resolved: 2009-12-11
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
Other JDK 6
1.4.0 h1191Fixed 6u18Fixed
Related Reports
Relates :  
Today on IRC someone reported they could not get v3 to work (admin console would not come up).  They ran into this error:

    Caused by: java.lang.UnsupportedOperationException: Cannot create XMLStreamReader or XMLEventReader from a javax.xml.transform.stream.StreamSource
        at com.sun.xml.internal.stream.XMLInputFactoryImpl.jaxpSourcetoXMLInputSource(XMLInputFactoryImpl.java:285)
        at com.sun.xml.internal.stream.XMLInputFactoryImpl.createXMLStreamReader(XMLInputFactoryImpl.java:145)
        at org.jvnet.hk2.config.ConfigParser.parse(ConfigParser.java:109)
        at org.jvnet.hk2.config.ConfigParser.parse(ConfigParser.java:104)
        at org.jvnet.hk2.config.ConfigParser.parse(ConfigParser.java:100)
        at org.glassfish.admingui.plugin.ConsolePluginService.init(ConsolePluginService.java:121)
        at org.glassfish.admingui.plugin.ConsolePluginService.getIntegrationPoints(ConsolePluginService.java:423)
        at org.glassfish.admingui.common.handlers.PluginHandlers.getIntegrationPoints(PluginHandlers.java:160)
        at org.glassfish.admingui.handlers.ThemeHandlers.getThemeFromIntegrationPoints(ThemeHandlers.java:98)
        ... 47 more

After spending some time looking into this, I finally found this post after doing a google search (should have done this first):


Which showed that using JDK 1.6.0_18-ea (at least on linux) does not work with GlassFish v3.  Downgrading to the latest stable release (1.6.0_16) solved that person's problem, it also solved the person's problem on IRC.

EVALUATION ChangeSet=http://hg.openjdk.java.net/jdk6/jdk6/jaxp/rev/5c070921580c,ChangeRequest=6923146,ChangeRequest=6917454,ChangeRequest=6472982,ChangeRequest=6909759,ChangeRequest=6333993,ChangeRequest=6900779,ChangeRequest=6900773,ChangeRequest=6900249,ChangeRequest=6675332,ChangeRequest=6889654,ChangeRequest=6889649,ChangeRequest=6863312

EVALUATION Fixed in jaxp 1.4. Request for integration. Original fix for issue 38 was 6631274.

EVALUATION SJSXP had an incomplete support for the optional method XMLInputFactory#createXMLStreamReader(Source source), which was reported in sjsxp issue 38 (https://sjsxp.dev.java.net/issues/show_bug.cgi?id=38). The change was then to remove the support and add a complete support in a future time as requested with sjsxp issue 39 (https://sjsxp.dev.java.net/issues/show_bug.cgi?id=39). This change, however, has caused regression in applications such as GlassFish v3. A quick fix for the issue would be to restore the code that supports StreamSource, but through UnsupportedOperationException for other sources.