From an e-mail I recently sent:
I noticed that some G1 parameters are very badly (and inconsistently) named!
1) G1DirtyCardQueueMax - maximum update buffer queue length before mutators start processing update buffers
2) DCQBarrierQueueBufferSize - length (it's not really size) of the update buffers
3) DCQBarrierProcessCompletedThreshold - how many update buffers must be in the queue before concurrent refinement threads start processing them
First, given that 2) and 3) are only used by G1, I think they should get the G1 prefix (and be moved to the g1_globals.hpp file). Second, I'd like to make the parameter names more consistent. These are the proposed new names: