JDK-6818864 : Memory management problem of JVM
  • Type: Bug
  • Component: hotspot
  • Sub-Component: compiler
  • Affected Version: 5.0u12
  • Priority: P4
  • Status: Closed
  • Resolution: Won't Fix
  • OS: solaris_10
  • CPU: sparc
  • Submitted: 2009-03-18
  • Updated: 2011-07-14
  • Resolved: 2011-07-14
Related Reports
Relates :  
The customer has several Amdocs environments installed on the detailed machine, each environment has several application servers. Approximately once a day one of the servers that belongs to one of their environments (randomly) starts to consume abnormal amounts of memory
Note: Each of the servers' memory consumption was limited using JVM ���Xmx and ���DmaxHeapMemory parameters to 1gb ��� 2gb.

Detailed description:

1. At first it was suspected to be an application memory leak but this option was ruled out once logs are cross referenced to the script log.

logs shows that no more than ~30% of the total memory that was allocated to the server was used and no exception occurred

while at the same time, the script log shows that the server used 4gb of memory which is about 4 times the memory allocated for this process. (using a bit more memory then what was allocated is normal but not using 4/5 times the amount of memory allocated).

2. The class histogram shows that no more than 917mb was used by objects in memory while at the same time the pmap script log shows that 4gb of memory was used.

EVALUATION 5.0 will phase out and we need escalation to fix it.

WORK AROUND * It is found out that in Jre 1.5.0_13 a similar behavior was observed: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6676462, so tried upgrading java version to 1.5.0_17 but that didn���t prevent the problem from reoccurring. * The suspicious thread was some kind of a compiler, our suspicion was that it was the JIT compiler. To test this out we disabled the JIT in the problematic environment (by enabling -Xint flag) and at the moment it seems to have solved the problem. I hope this helps detect the root cause of this problem. comments : (company - amdocs , email - ###@###.###)