JDK-6696175 : javaws not recognizing properties which contains % character
  • Type: Bug
  • Component: deploy
  • Sub-Component: webstart
  • Affected Version: 5.0u15
  • Priority: P2
  • Status: Resolved
  • Resolution: Fixed
  • OS: linux,windows_xp
  • CPU: generic,x86,sparc
  • Submitted: 2008-04-30
  • Updated: 2011-02-16
  • Resolved: 2009-04-06
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
Other JDK 6 JDK 7
5.0u18-rev b05Fixed 6u12Fixed 7Fixed
Description
Java Web Start is not recognizing the properties which contains % character.
 The customer seeing this issue with particular versions of Java Web Start like
1.5.0_15 and 1.6.0_06 .
This issue didn't happen with previous versions 1.5.0_06,1.5.0_07,1.5.0_11,
1.5.0_14, 1.6.0_02, 1.6.0.03, 1.6.0_04


For Example,.
<property name='user' value='chandra%'/>
<property name='version' value='1.1'</property>
<property name='sessionId' value='afg4l5n55%bn3'/>
<property name='cookie' value='abcdefghijk'/>

The properties with % character are not getting loaded

If they download the jnlp file, the property is there, If they choose to view
jnlp file in "javaws -viewer" it's not there.

The customer is not using URL encoding  as the specification mentions % symbol requires special encoding.

http://java.sun.com/products/javawebstart/jnlp-spec-log.html


Customer's version :

We tested this on Windows.Issue is not on the server side but on client side.
We tried launching from IE as well as Mozilla Firefox

Yes, this issue didn't happen with versions 1.5.0_06,1.5.0_07,1.5.0_11,
1.5.0_14, 1.6.0_02, 1.6.0.03, 1.6.0_04
Yes this issue is happening after installing the newer version i.e
1.5.0_15 or 1.6.0_06

Since I have multiple JREs, I am launching with the corresponding versions.
For Ex, with command line, the way I launch the javaws -viewer is as follows

C:\> "C:\program files\java\jre1,5,0_07\bin\javaws" -viewer

With browser also, I am selecting the javaws corresponding to the version which I want to test.
I opened a thread even in the forum and saw one more person is having the same issue

http://forum.java.sun.com/thread.jspa?threadID=5288639

This issue is happening for me whenever we have % character.

Comments
EVALUATION the fix to 6623233 is in 6u10, and may be overly agressive. We need to evaluate the impact of allowing % characters in property values.
09-10-2008

EVALUATION Please see more details on the Comments section. The changes that caused this regression on 6u5 may not exist in 6u10 since those changes are not seen with the latest ws anymore. Need to confirm by testing it.
26-06-2008