JDK-6678638 : cache entry update is broken
  • Type: Bug
  • Component: deploy
  • Sub-Component: deployment_toolkit
  • Affected Version: 6u10
  • Priority: P1
  • Status: Closed
  • Resolution: Fixed
  • OS: generic
  • CPU: generic
  • Submitted: 2008-03-21
  • Updated: 2010-09-17
  • Resolved: 2008-05-16
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
6u10 b21Fixed 7Fixed
I tried last night build, and there is still problem with java web start.

I tried running the association test case, excessive relaunch is gone, but I found 3 problems by looking at the trace:


1.  We are always trying to download .pack.gz , even for .jnlp file.  But the jnlp file does not have jnlp.packEnabled set.

2.  The above webserver seems to always return 200 for update check, so each time a new download is done.   But looks like we are not removing/invalidating previous cache entry, after we downloaded a new cache entry.

EVALUATION regression caused by: 6668033 java_plugin/plugin2 New plugin applet freezes the browser occasionally we are always doing update check with .pack.gz extension; and we fail to remove/invalidate old cache entry when we update a new cache entry