JDK-6645033 : Internal Error 2753. regutils.dll - While Re-installing JRE6u10
  • Type: Bug
  • Component: install
  • Sub-Component: install
  • Affected Version: 6u10
  • Priority: P4
  • Status: Resolved
  • Resolution: Won't Fix
  • OS: windows_xp
  • CPU: x86
  • Submitted: 2007-12-23
  • Updated: 2013-06-11
  • Resolved: 2013-06-11
Related Reports
Relates :  
Internal Error 2753. regutil.dll - While Re-installing JRE6u10 b09 PIT
Got this error while re-installing JRE. Looks like it is not able to access the registry key. I am not able to reproduce this either. Attached the screen shot. 

I found this error in my desktop ( 
I am sorry I dont know the MSI log corresponds to it . There is a  bunch of MSI logs in my m/c but none of them contains this error. So I dont know which one is corresponds to this installation. 

Attached all the MSI logs .
See http://forums.java.net/jive/thread.jspa?messageID=308897

While investigating the error, I found a way to cause Internal Error 2753. regutils.dll

I don't know how a higher version regutils.dll would be left in the C:\Program Files\Java\jre6 directory, but if one is, it causes the Error 2753.

Install 6u11 JRE
Copy C:\Program Files\Java\jre6\bin\regutils.dll to a temporary directory.
Uninstall 6u11 JRE
Copy the file from the temporary directory to C:\Program Files\Java\jre6\bin\regutils.dll
Install 6u10 JRE.

Expected: 6u10 installs
Actual: Internal Error 2753. regutils.dll

Workaround: delete C:\Program Files\Java\jre6\bin\regutils.dll

N/A for JDK8.

EVALUATION I'm not sure of the reproducibility of the original CR. I found a way to reproduce the reported error. I used 6u10 and 6u11 builds that might have had regutil.dll's with different exported entry points. A number of originally 6u11 changes were putback in 6u10 before it released, so it might not be reproducible with 6u10 GA and 6u11 GA. Component: jr; Installed: Absent; Request: Local; Action: Null says the jr component was requested to be installed (locally), but the install isn't going to do it (Action: Null) I would want to see Component: jr; Installed: Absent; Request: Local; Action: Local where the component would overwrite the regutils.dll that was there. I thought you changed to Action: Local by setting the right MSI / component properties, not by updating the internals during InstallValidate. Instead of the component property Never Overwrite=No, it is almost like need an Always Overwrite (even with older version) By setting the InstallMode of regutils.dll in the RemoveFiles table from 2 to 3, I was trying to get a 6u10 install to overwrite a 6u11 regutils.dll.

EVALUATION Clarification: I tried setting the InstallMode of regutils.dll in the RemoveFiles table from 2 to 3 AND it still failed. See attached MSIdb0b2.LOG for the failure when InstallMode was changed to 3. MSIdb0b2.LOG contains: Action start 14:47:09: unzipcore. MSI (s) (E8:40) [14:47:09:939]: Note: 1: 2753 2: regutils.dll DEBUG: Error 2753: The File 'regutils.dll' is not marked for installation. Internal Error 2753. regutils.dll MSI (s) (E8:40) [14:47:27:454]: Product: Java(TM) 6 Update 10 -- Internal Error 2753. regutils.dll Action ended 14:47:27: unzipcore. Return value 3. The problem is related to the jr component's Action state of Null during InstallValidate. It should be Action: Local like many other components. MSI (s) (E8:40) [14:47:02:247]: Component: jr; Installed: Absent; Request: Local; Action: Null

WORK AROUND Delete the install directory before running the install.

EVALUATION It doesn't look like the remove file table wants to remove regutils.dll. (I tried setting the InstallMode of regutils.dll in the RemoveFiles table from 2 to 3.) See attached MSIdb0b2.LOG

EVALUATION Changing the RemoveFile table to remove regutils.dll during install might fix this. I don't think Windows Installer can be convinced to overwrite a newer file.

EVALUATION Closing this as not reproducible. If anyone finds a way to reproduce, we can reopen.