JDK-6642046 : Main not found then installation of component get started
  • Type: Bug
  • Component: deploy
  • Sub-Component: deployment_toolkit
  • Affected Version: beta
  • Priority: P3
  • Status: Closed
  • Resolution: Fixed
  • OS: windows_xp
  • CPU: x86
  • Submitted: 2007-12-14
  • Updated: 2011-02-16
  • Resolved: 2008-05-16
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
6u10 b23Fixed
I have just tried to run 2-3 games from sun site, its all jnlp application. So, before running the installation its giving error" main not found " then it starts installing component. This error message is very wired.
I am able to reproduce this in my machine ( Vnc Password :vnc)

These are the steps to reproduce the issue

1.clear cache & Install 1.5.0 ( tried with 1.5.0_08 and 1.5.0_14)
2.Install kernel JRE (I used promoted build 6u10b11)
3.launch a JNLP application (
javaws http://ebugster.sfbay.sun.com/dev/ebugster.jnlp or
javaws http://java.sun.com/products/javawebstart/apps/notepad.jnlp )

4. "Main Class Not Found .Program Will Exit " dialog will be displayed.
5. Clicking Ok  disposes the dialog and the application launches successfully.

This error dialog is displayed only once after an installation.Second time the error dialog is not displayed.

This doesn't happen if I repeat the steps using 1.4.2 in step 1.

I am not able to reproduce the same bug in all  XP Prof machines.
Its not reproducible in  jlab424.india.sun.com (VNC Pwd:vnc123),but reproducible in jdsn9.india.sun.com((VNC Pwd:vnc123))

During webstart automation I am getting this same error dialog (Main Class Not Found.Program Will Exit) for only these three tests
suite_javaws_pickupJRE /from before_upgraded
suite_javaws_pickupJRE /after_reinstalled
suite_javaws_pickupJRE /from jaws150
.If I click Ok for the dialog,the test will pass.otherwise other tests (total 7 tests) also will fail bcoz of timeout.This error is reproducible in all the machines.

All the tests in this suite deals with picking up previous JREs(1.4.2 and 1.5.0 )But other  tests in this suite are passing.

I am getting this errror in console after running suite_javaws_pickupJRE/from jaws150
TEST from_jaws150 from_jaws150 7/7 7/7 FAIL
Got "java.io.IOException: Cannot run program "C:/Program Files/Java/jr
a": CreateProcess error=2, The system cannot find the file specified"
cution of "${TEST_JRE_HOME}/bin/java  -cp ${COMPONENT_WS}/share/lib/cl
in.jar CloseNativeWindow Java(TM)  "
HARNESS ENDED: Mon Feb 04 22:41:29 GMT+05:30 2008

EVALUATION javaws.exe was attempting to run JRELocator to update the JRE information. JRELocator lives in deploy.jar, which is not part of the Kernel core. The Kernel JRE itself handles this situation just fine, of course, and downloads deploy.jar when required. But other JREs simply fail when pointed to a nonexistent deploy.jar. Fix is to have javaws.exe check for the presence of its own deploy.jar first, downloading it if needed, before calling any JRELocators.

EVALUATION Please provide the jnlp urls.