JDK-6634510 : Patch in Place fails after installing 6u10 kernel
  • Type: Bug
  • Component: deploy
  • Sub-Component: deployment_toolkit
  • Affected Version: cascabel,6u10
  • Priority: P1
  • Status: Closed
  • Resolution: Fixed
  • OS:
    solaris_10,windows,windows_xp,windows_vista solaris_10,windows,windows_xp,windows_vista
  • CPU: x86,sparc
  • Submitted: 2007-11-27
  • Updated: 2010-09-08
  • Resolved: 2008-01-31
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
6u10 b10Fixed
Related Reports
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
I installed 6u10 b07 kernel.  It installed fine.  I waited for kernel to finish before launching the 6u11 online install.
When I tried to patch-in-place to 6u12, patchjre failed with a mismatch error.

6u10 non-kernel online install to 6u12 using patch-in-place worked.

I am guessing that files left by java kernel do not match files installed by the non-java kernel install.

EVALUATION I was unaware that the install build was creating a modified jre-image, so the "target" which kernel was trying to establish byte-for-byte compatibility with wasn't exactly what was being installed. Fixed by waiting to invoke SplitJRE until just before creating patch-image.zip.

EVALUATION I reassign this to Ethan for evaluation since I am not familar with the kernel makefiles.

EVALUATION Jennifer, please look into the build and make sure the kernel is being built with the same files as the non-kernel build. If it is, please reassign to kernel team. When applying 6u10 to 6u11 patch, the warning: bin\awt.dll: Old File not found. However, a file of the same name was found. No update done since the file contents do not match. is displayed. The awt.dll file has a different chksum and a different timestamp. The non-kernel file is: C:\Program Files\Java\Copy of jre6 - save non-kernel online install\bin\>dir awt.dll 11/28/2007 11:44 AM 1,150,976 awt.dll C:\Program Files\Java\Copy of jre6 - save non-kernel online install\bin\>cksum awt.dll 2124004920 1150976 awt.dll The awt.dll file installed by kernel: C:\Program Files\Java\jre6\bin>dir awt.dll Directory of C:\Program Files\Java\jre6\bin 11/28/2007 01:08 PM 1,150,976 awt.dll 1 File(s) 1,150,976 bytes C:\Program Files\Java\jre6\bin>cksum awt.dll 2220987848 1150976 awt.dll