JDK-6184339 : Java Plugin Fatal Error- Can Not load class sun/plugin/JavaRunTime
  • Type: Bug
  • Component: install
  • Sub-Component: install
  • Affected Version: 5.0
  • Priority: P3
  • Status: Closed
  • Resolution: Duplicate
  • OS: windows_2000
  • CPU: x86
  • Submitted: 2004-10-26
  • Updated: 2010-04-02
  • Resolved: 2005-11-02
Related Reports
Duplicate :  
Description
FULL PRODUCT VERSION :
java version "1.5.0"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0-b64)
Java HotSpot(TM) Client VM (build 1.5.0-b64, mixed mode, sharing)

ADDITIONAL OS VERSION INFORMATION :
Windows 2000 Build 2195 Service Pack 4

A DESCRIPTION OF THE PROBLEM :
After installing JDK 1.5 downloaded from the Sun's website, when I launch my Java Web Application, I get an error that says:

Java Plug-in Fatal Error

Cannot load class sun/plugin/JavaRunTime.

The bridge was installed at <C:\Program~1\Java\JRE15~1.0> but the class is not there
Modify the registry key to reflect the new bridge location
The key is HKEY_LOCAL_MACHINE\SOFTWARE\Java Plug-in
or change your CLASSPATH to include the new directory.

I tried reinstalling  Windows Online Installation, Multi-language (jdk-1_5_0-windows-i586-iftw.exe, 221.25 KB) , but the problem doesn't go away even after rebooting the system after install.

I searched through the java forum and found that there are others having similar problems.

http://forum.java.sun.com/thread.jsp?forum=37&thread=559238&tstart=0&trange=15

STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
I had JRE 1.4.2_05 installed.

Downloaded and installed J2SE(TM) Development Kit 5.0

Rebooted sstem.

Launched my Java Web Application that used to worked with JRE  1.4.2_05. The JNLP link that I clicked using IE doesn't cause my application to launch.

Get the error message described above. Application doesn't launch.

EXPECTED VERSUS ACTUAL BEHAVIOR :
EXPECTED -
Application should launch.
ACTUAL -
Popup Box that says:
Java Plug-in Fatal Error

Cannot load class sun/plugin/JavaRunTime.

The bridge was installed at <C:\Program~1\Java\JRE15~1.0> but the class is not there
Modify the registry key to reflect the new bridge location
The key is HKEY_LOCAL_MACHINE\SOFTWARE\Java Plug-in
or change your CLASSPATH to include the new directory.




ERROR MESSAGES/STACK TRACES THAT OCCUR :
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d3e791e, pid=2284, tid=2096
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0-b64 mixed mode, sharing)
# Problematic frame:
# C  [jpicom32.dll+0x791e]
#

---------------  T H R E A D  ---------------

Current thread (0x03385cc0):  JavaThread "Thread-4" [_thread_in_native, id=2096]

siginfo: ExceptionCode=0xc0000005, reading address 0x00000000

Registers:
EAX=0x00000000, EBX=0x0000000d, ECX=0x03379894, EDX=0x77fd0170
ESP=0x043ebbcc, EBP=0x043ebbec, ESI=0x00000000, EDI=0x043ebd28
EIP=0x6d3e791e, EFLAGS=0x00010246

  Top of Stack: (sp=0x043ebbcc)
0x043ebbcc:   00000000 6d3e796b 0337a9b4 0000001e
0x043ebbdc:   6d3e7956 043ebc28 6d3e9bc4 ffffffff
0x043ebbec:   043ebc38 6d3e331a 0000001c 0000001e
0x043ebbfc:   6d4056ca 03379894 00000000 0000001c
0x043ebc0c:   00000000 6d405811 043ebd28 7c5901d5
0x043ebc1c:   0000000d 043ed2a4 043eb818 043ed2a4
0x043ebc2c:   6d40a0c6 6d40ba40 00000000 043ebe38
0x043ebc3c:   6d591abf 6d597990 043ec79c 043ebef0

Instructions: (pc=0x6d3e791e)
0x6d3e790e:   5e c2 04 00 a1 18 05 3f 6d c3 a1 18 05 3f 6d 50
0x6d3e791e:   8b 08 ff 51 14 c3 8b 44 24 04 a3 18 05 3f 6d c3


Stack: [0x043b0000,0x043f0000),  sp=0x043ebbcc,  free space=238k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  [jpicom32.dll+0x791e]
C  [jpicom32.dll+0x331a]
C  [npjpi150.dll+0x1abf]
C  [ole32.dll+0x6d546]
C  [ole32.dll+0x6d97a]
C  [ole32.dll+0x6f37c]
C  [ole32.dll+0xbf9ff]
C  [ole32.dll+0x70065]
C  [ole32.dll+0x70038]
C  [ole32.dll+0x6ff47]
C  [ole32.dll+0x6fec1]
C  [ole32.dll+0xbf9ff]
C  [ole32.dll+0xbf9ff]
C  [ole32.dll+0x6afb2]
C  [ole32.dll+0x40a3a]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  com.sun.deploy.net.proxy.WIExplorerAutoProxyHandler.evalScript(Ljava/lang/String;)Ljava/lang/String;+0
j  com.sun.deploy.net.proxy.WIExplorerAutoProxyHandler.getProxyInfo(Ljava/net/URL;)[Lcom/sun/deploy/net/proxy/ProxyInfo;+60
j  com.sun.deploy.net.proxy.DynamicProxyManager.getProxyInfo(Ljava/net/URL;)Lcom/sun/deploy/net/proxy/ProxyInfo;+96
j  com.sun.deploy.net.proxy.DeployProxySelector.select(Ljava/net/URI;)Ljava/util/List;+114
j  sun.net.www.protocol.http.HttpURLConnection.plainConnect()V+187
j  sun.net.www.protocol.http.HttpURLConnection.connect()V+1
j  com.sun.javaws.net.BasicNetworkLayer.doRequest(Ljava/net/URL;Z[Ljava/lang/String;[Ljava/lang/String;Z)Lcom/sun/javaws/net/HttpResponse;+156
j  com.sun.javaws.net.BasicNetworkLayer.doHeadRequest(Ljava/net/URL;)Lcom/sun/javaws/net/HttpResponse;+6
j  com.sun.javaws.cache.DownloadProtocol.doDownload(Lcom/sun/javaws/cache/DownloadProtocol$DownloadInfo;Lcom/sun/javaws/cache/DownloadProtocol$DownloadAction;)V+186
j  com.sun.javaws.cache.DownloadProtocol.isUpdateAvailable(Ljava/net/URL;Ljava/lang/String;I)Z+33
j  com.sun.javaws.cache.CacheImageLoader$DelayedImageLoader.run()V+23
v  ~StubRoutines::call_stub

---------------  P R O C E S S  ---------------

Java Threads: ( => current thread )
=>0x03385cc0 JavaThread "Thread-4" [_thread_in_native, id=2096]
  0x00747b68 JavaThread "DestroyJavaVM" [_thread_blocked, id=1928]
  0x033826e8 JavaThread "javawsApplicationMain" [_thread_blocked, id=2124]
  0x03375b68 JavaThread "TimerQueue" daemon [_thread_blocked, id=2128]
  0x0335f6e8 JavaThread "ConsoleWriterThread" daemon [_thread_blocked, id=2252]
  0x0334ad70 JavaThread "AWT-EventQueue-0" [_thread_blocked, id=2116]
  0x00a24ab0 JavaThread "AWT-Shutdown" [_thread_blocked, id=2056]
  0x032fd988 JavaThread "Java2D Disposer" daemon [_thread_blocked, id=1756]
  0x032f88e0 JavaThread "traceMsgQueueThread" [_thread_blocked, id=1960]
  0x00a24f80 JavaThread "AWT-Windows" daemon [_thread_in_native, id=1964]
  0x009d4ce8 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=1996]
  0x009d37f0 JavaThread "CompilerThread0" daemon [_thread_blocked, id=2196]
  0x009d2a88 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=2188]
  0x009a3e10 JavaThread "Finalizer" daemon [_thread_blocked, id=2300]
  0x009a28f8 JavaThread "Reference Handler" daemon [_thread_blocked, id=2208]

Other Threads:
  0x009cf5f0 VMThread [id=1428]
  0x009d6280 WatcherThread [id=2340]

VM state:not at safepoint (normal execution)

VM Mutex/Monitor currently owned by a thread: None

Heap
 def new generation   total 576K, used 192K [0x22ab0000, 0x22b50000, 0x22f90000)
  eden space 512K,  37% used [0x22ab0000, 0x22adfca8, 0x22b30000)
  from space 64K,   1% used [0x22b30000, 0x22b303d8, 0x22b40000)
  to   space 64K,   0% used [0x22b40000, 0x22b40000, 0x22b50000)
 tenured generation   total 2144K, used 1284K [0x22f90000, 0x231a8000, 0x26ab0000)
   the space 2144K,  59% used [0x22f90000, 0x230d1300, 0x230d1400, 0x231a8000)
 compacting perm gen  total 8192K, used 1437K [0x26ab0000, 0x272b0000, 0x2aab0000)
   the space 8192K,  17% used [0x26ab0000, 0x26c177d0, 0x26c17800, 0x272b0000)
    ro space 8192K,  62% used [0x2aab0000, 0x2afb7160, 0x2afb7200, 0x2b2b0000)
    rw space 12288K,  46% used [0x2b2b0000, 0x2b83c1c0, 0x2b83c200, 0x2beb0000)

Dynamic libraries:
0x00400000 - 0x0040c000 	C:\Program Files\Java\jre1.5.0\bin\javaw.exe
0x77f80000 - 0x77ffd000 	C:\WINNT\system32\ntdll.dll
0x7c2d0000 - 0x7c332000 	C:\WINNT\system32\ADVAPI32.dll
0x7c570000 - 0x7c623000 	C:\WINNT\system32\KERNEL32.DLL
0x77d30000 - 0x77da1000 	C:\WINNT\system32\RPCRT4.DLL
0x77e10000 - 0x77e75000 	C:\WINNT\system32\USER32.dll
0x77f40000 - 0x77f7b000 	C:\WINNT\system32\GDI32.DLL
0x78000000 - 0x78045000 	C:\WINNT\system32\MSVCRT.dll
0x75e60000 - 0x75e7a000 	C:\WINNT\system32\IMM32.DLL
0x6ca60000 - 0x6ca68000 	C:\WINNT\system32\LPK.DLL
0x66650000 - 0x666a4000 	C:\WINNT\system32\USP10.dll
0x6d640000 - 0x6d7c5000 	C:\Program Files\Java\jre1.5.0\bin\client\jvm.dll
0x77570000 - 0x775a0000 	C:\WINNT\system32\WINMM.dll
0x6d280000 - 0x6d288000 	C:\Program Files\Java\jre1.5.0\bin\hpi.dll
0x690a0000 - 0x690ab000 	C:\WINNT\system32\PSAPI.DLL
0x6d610000 - 0x6d61c000 	C:\Program Files\Java\jre1.5.0\bin\verify.dll
0x6d300000 - 0x6d31d000 	C:\Program Files\Java\jre1.5.0\bin\java.dll
0x6d630000 - 0x6d63f000 	C:\Program Files\Java\jre1.5.0\bin\zip.dll
0x6d000000 - 0x6d166000 	C:\Program Files\Java\jre1.5.0\bin\awt.dll
0x77800000 - 0x7781e000 	C:\WINNT\system32\WINSPOOL.DRV
0x76620000 - 0x76630000 	C:\WINNT\system32\MPR.DLL
0x77a50000 - 0x77b3f000 	C:\WINNT\system32\ole32.dll
0x51000000 - 0x51044000 	C:\WINNT\system32\ddraw.dll
0x728a0000 - 0x728a6000 	C:\WINNT\system32\DCIMAN32.dll
0x5c000000 - 0x5c0c7000 	C:\WINNT\system32\D3DIM700.DLL
0x6d1f0000 - 0x6d203000 	C:\Program Files\Java\jre1.5.0\bin\deploy.dll
0x63000000 - 0x63096000 	C:\WINNT\system32\WININET.dll
0x7c740000 - 0x7c7c7000 	C:\WINNT\system32\CRYPT32.dll
0x77430000 - 0x77440000 	C:\WINNT\system32\MSASN1.DLL
0x779b0000 - 0x77a4b000 	C:\WINNT\system32\OLEAUT32.dll
0x63180000 - 0x631e9000 	C:\WINNT\system32\SHLWAPI.dll
0x1a400000 - 0x1a47b000 	C:\WINNT\system32\urlmon.dll
0x77820000 - 0x77827000 	C:\WINNT\system32\VERSION.dll
0x759b0000 - 0x759b6000 	C:\WINNT\system32\LZ32.DLL
0x782f0000 - 0x78535000 	C:\WINNT\system32\SHELL32.dll
0x71710000 - 0x71794000 	C:\WINNT\system32\COMCTL32.dll
0x6d5d0000 - 0x6d5ed000 	C:\Program Files\Java\jre1.5.0\bin\RegUtils.dll
0x034f0000 - 0x036f4000 	C:\WINNT\system32\msi.dll
0x6d240000 - 0x6d27d000 	C:\Program Files\Java\jre1.5.0\bin\fontmanager.dll
0x6d4c0000 - 0x6d4d3000 	C:\Program Files\Java\jre1.5.0\bin\net.dll
0x75030000 - 0x75044000 	C:\WINNT\system32\WS2_32.dll
0x75020000 - 0x75028000 	C:\WINNT\system32\WS2HELP.DLL
0x6d4e0000 - 0x6d4e9000 	C:\Program Files\Java\jre1.5.0\bin\nio.dll
0x774e0000 - 0x77513000 	C:\WINNT\system32\RASAPI32.DLL
0x774c0000 - 0x774d1000 	C:\WINNT\system32\RASMAN.DLL
0x77530000 - 0x77552000 	C:\WINNT\system32\TAPI32.DLL
0x77830000 - 0x7783e000 	C:\WINNT\system32\RTUTILS.DLL
0x75ab0000 - 0x75ab5000 	C:\WINNT\system32\sensapi.dll
0x7c0f0000 - 0x7c151000 	C:\WINNT\system32\USERENV.DLL
0x75170000 - 0x751bf000 	C:\WINNT\system32\netapi32.dll
0x7c340000 - 0x7c34f000 	C:\WINNT\system32\Secur32.dll
0x77bf0000 - 0x77c01000 	C:\WINNT\system32\NTDSAPI.dll
0x77980000 - 0x779a4000 	C:\WINNT\system32\DNSAPI.DLL
0x75050000 - 0x75058000 	C:\WINNT\system32\WSOCK32.DLL
0x77950000 - 0x7797a000 	C:\WINNT\system32\WLDAP32.DLL
0x751c0000 - 0x751c6000 	C:\WINNT\system32\NETRAP.dll
0x75150000 - 0x7515f000 	C:\WINNT\system32\SAMLIB.dll
0x782c0000 - 0x782cc000 	C:\WINNT\System32\rnr20.dll
0x77340000 - 0x77353000 	C:\WINNT\system32\iphlpapi.dll
0x77520000 - 0x77525000 	C:\WINNT\system32\ICMP.DLL
0x77320000 - 0x77337000 	C:\WINNT\system32\MPRAPI.DLL
0x773b0000 - 0x773df000 	C:\WINNT\system32\ACTIVEDS.DLL
0x77380000 - 0x773a3000 	C:\WINNT\system32\ADSLDPC.DLL
0x77880000 - 0x7790e000 	C:\WINNT\system32\SETUPAPI.DLL
0x77360000 - 0x77379000 	C:\WINNT\system32\DHCPCSVC.DLL
0x777e0000 - 0x777e8000 	C:\WINNT\System32\winrnr.dll
0x10000000 - 0x1001c000 	C:\WINNT\System32\hclsock5.dll
0x777f0000 - 0x777f5000 	C:\WINNT\system32\rasadhlp.dll
0x74fd0000 - 0x74fee000 	C:\WINNT\system32\msafd.dll
0x75010000 - 0x75017000 	C:\WINNT\System32\wshtcpip.dll
0x775a0000 - 0x77630000 	C:\WINNT\system32\CLBCATQ.DLL
0x6b700000 - 0x6b790000 	C:\WINNT\System32\jscript.dll
0x6d590000 - 0x6d5a1000 	C:\Program Files\Java\jre1.5.0\bin\npjpi150.dll
0x695e0000 - 0x69609000 	C:\WINNT\system32\OLEPRO32.DLL
0x6d400000 - 0x6d417000 	C:\Program Files\Java\jre1.5.0\bin\jpiexp32.dll
0x6d450000 - 0x6d468000 	C:\Program Files\Java\jre1.5.0\bin\jpishare.dll
0x6d1c0000 - 0x6d1e3000 	C:\Program Files\Java\jre1.5.0\bin\dcpr.dll
0x6d3e0000 - 0x6d3f4000 	C:\Program Files\Java\jre1.5.0\bin\jpicom32.dll

VM Arguments:
jvm_args: -Xbootclasspath/a:C:\Program Files\Java\jre1.5.0\lib\javaws.jar;C:\Program Files\Java\jre1.5.0\lib\deploy.jar -Djnlpx.home=C:\Program Files\Java\jre1.5.0\bin -Djnlpx.splashport=1827 -Djnlpx.jvm="C:\Program Files\Java\jre1.5.0\bin\javaw.exe" -Djnlpx.remove=true -Djava.security.policy=file:C:\Program Files\Java\jre1.5.0\lib\security\javaws.policy -DtrustProxy=true -Xverify:remote -Djnlpx.heapsize=NULL,NULL
java_command: com.sun.javaws.Main C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\javaws31

Environment Variables:
CLASSPATH=.;C:\SQLLIB\java\db2javaold.zip;C:\SQLLIB\java\db2jccold.jar;C:\SQLLIB\java\sqljold.zip;C:\SQLLIB\bin;C:\SQLLIB\java\commonold.jar
PATH=C:\PROGRA~1\Java\JRE15~1.0\bin;C:\Program Files\Java\jre1.5.0\bin;C:\Program Files\Internet Explorer;;C:\PROGRA~1\Borland\CBUILD~1\Projects\Bpl;C:\PROGRA~1\Borland\CBUILD~1\Bin;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\Program Files\IBM\Trace Facility;C:\Program Files\Personal Communications;C:\Notes;C:\Utilities;c:\j2sdk1.4.2_05\bin;c:\Visual Explain;C:\WebSphere\AppServer\bin;C:\Program Files\Rational\common;C:\SQLLIB\BIN;C:\SQLLIB\FUNCTION;"C:\Program Files\Java\jre1.5.0\bin";.
USERNAME=v2cdi02
OS=Windows_NT
PROCESSOR_IDENTIFIER=x86 Family 15 Model 1 Stepping 2, GenuineIntel


---------------  S Y S T E M  ---------------

OS: Windows 2000 Build 2195 Service Pack 4

CPU:total 1 family 15, cmov, cx8, fxsr, mmx, sse, sse2, ht

Memory: 4k page, physical 522992k(231848k free), swap 1276608k(943500k free)

vm_info: Java HotSpot(TM) Client VM (1.5.0-b64) for windows-x86, built on Sep 15 2004 03:00:31 by "java_re" with MS VC++ 6.0



REPRODUCIBILITY :
This bug can be reproduced always.

CUSTOMER SUBMITTED WORKAROUND :
Revert back to using JRE 1.4.2_05
###@###.### 10/26/04 02:39 GMT

Comments
EVALUATION This could happen only if the JRE installation is not complete. I suspect that either <jre_home>\lib\plugin.jar is not present or it is invalid. ###@###.### 10/27/04 17:42 GMT This is a false message given by Plug-in We are using wrong messages in the plug-in startup code. Look for IDS_PLUGIN_MOVED and IDS_PLUGIN_NEVERINSTALLED in the file src/plugin/win32/jpishare/CActivatorJNI.cpp The above comment is from Deva ###@###.### 2004-12-02 21:21:54 GMT Can we ask the submitter to verify if the jre_home>\lib\plugin.jar file is present and valid? ###@###.### 2005-04-19 20:22:56 GMT
27-10-2004