JDK-4476448 : There is a bug when finding updates on passworded servers
  • Type: Bug
  • Component: deploy
  • Sub-Component: webstart
  • Affected Version: 1.0,1.0.1
  • Priority: P4
  • Status: Closed
  • Resolution: Fixed
  • OS:
    generic,windows_95,windows_98,windows_nt,windows_2000 generic,windows_95,windows_98,windows_nt,windows_2000
  • CPU: generic,x86
  • Submitted: 2001-06-29
  • Updated: 2002-08-02
  • Resolved: 2002-02-11
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availability Release.

To download the current JDK release, click here.
Other
1.2.0 1.2Fixed
Related Reports
Duplicate :  
Duplicate :  
Duplicate :  
Description
The customer email below describe it clearly:

The following are the steps taken that caused the bug to occur:

1. I loaded the .jar file for the application onto our server and created
the .jnlp file.
2. At a different computer running JWS I linked to the .jnlp file, and JWS
was activated.
3. JWS asked me for a username and password, which I entered.
4. The application started and worked fine.
5. I then updated the .jar file on the server.
6. I started JWS on the other computer and began the application.
7. I was prompted for a pasword and quickly moved the password dialog box
out of the way of the application's window.
8. The application window of the previous version poped up immediately.
9. After I entered the username and password, the password dialog box
dissapeared and I was able to use the older version of the application
without  incident.
10. After quitting the application and restarting through JWS the same
process occured without the updated version being downloaded.
11.  In order to test the update, I removed the password on our server for a
short span of time and ran the application through JWS.
12. The application was updated and ran smoothly.

The password protection on the server must remain on, however, so taking it
off to allow for updates is, unfortunately, not an option.


Name: tn108358			Date: 06/29/2001


I use a Java IDE and its Java SDK (java1.2)

I am trying to distribute a Java application off of a password-locked server.
Once I have downloaded the application, an imageviewer, once, I can work in it
without a problem.  However when I close it and try to run it again, the
password dialog box pops up.  Immediately after the password box appears, the
application I am trying to run appears over the password box.  Because the
password box is active, the application window is inactive and cannot be moved
or closed.  If I quicky move the password box to the side of the screen where
it will not be covered by the application, I can enter my password and activate
the application window; however Java Web Start will not update the application.
(Review ID: 127507) 
======================================================================
thomas.v.ng@east 2001-06-29

Comments
CONVERTED DATA BugTraq+ Release Management Values COMMIT TO FIX: 1.2 hopper FIXED IN: 1.2 hopper INTEGRATED IN: 1.2 hopper VERIFIED IN: 1.2 hopper-rc
2004-08-31

EVALUATION Rene: In Line 99, we actually do a download of the JNLP file in some circumstances, but the authenticator is first setup in line 125. That seems problematic. I tried to switch their orders, and now it seems like it will pick up the updates, but the password dialog is behind the update/download window and I cannot access it. So now we need to figure out how to make the password dialog in focus. thomas.v.ng@east 2001-06-29
2001-06-29