JDK-4393876 : JTextArea does not add characters for special key-strokes (such as '<' and '>')
  • Type: Bug
  • Component: client-libs
  • Sub-Component: java.awt
  • Affected Version: 1.3.0
  • Priority: P4
  • Status: Closed
  • Resolution: Duplicate
  • OS: generic
  • CPU: generic
  • Submitted: 2000-11-30
  • Updated: 2001-04-22
  • Resolved: 2001-04-22
Related Reports
Duplicate :  
Relates :  
Description

Name: rmT116609			Date: 11/30/2000


java version "1.3.0_01"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0_01)
Java HotSpot(TM) Client VM (build 1.3.0_01, mixed mode)

(i also tried the original 1.3.0 release)

I am building a text editor, called FTX. First i used J2SDK 1.2.2, and
everything worked fine. Now i upgraded to J2SDK 1.3 for Linux, and the JTextArea
does not work very well. When i type a char like '<' or '>' or '+', it simply
does not show up on the JTextArea. I've tried my text editor on J2SDK for
windows, and it works fine. So it has to be a problem with the SDK for Linux.

All of my source code is published on www.ftx.cjb.net -please fo on and download
if you cannot reproduce the problem. I'm certain, though, that nothing is wrong
with my application, and that this problem occurs however you are using your
JTextArea.

Specifications on my system: Red Hat Linux 7.0, XFree86 v4.01, J2SDK 1.3.0,
swedish keyboard (which works fine in all other applications).
(Review ID: 112190) 
======================================================================

Comments
WORK AROUND Name: rmT116609 Date: 11/30/2000 Nothing i can think of. ======================================================================
2004-06-11

EVALUATION This is likely another manifestation of 4435010. scott.violet@eng 2001-04-07 This sounds exactly like bugid 4371923. I have emailed the submitter to have him verify that this problem is fixed in ladybird-beta. eric.hawkes@eng 2001-04-08 The submitter did not respond to my email. I'm pretty sure this is a duplicate of 4371923, so I am closing it as such. eric.hawkes@eng 2001-04-21
2001-04-08