JDK-8020941 : DRS: Make ruleset element version attribute mandatory
  • Type: Enhancement
  • Status: Closed
  • Resolution: Fixed
  • Component: deploy
  • Sub-Component: deployment_toolkit
  • Priority: P2
  • Submit Date: 2013-07-19
  • Updated Date: 2014-02-12
  • Resolved Date: 2013-07-23
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availabitlity Release.

To download the current JDK release, click here.
JDK 7 JDK 8
7u40 b35Fixed 8Fixed
Description
    - update code to generate parsing exception on ruleset w/o version.
    - update internal docs and DTD to reflect that version is mandatory
    - update development test cases to make sure version is there and add negative case.
    - (Joni) update external docs, examples, and DTD to reflect that version is mandatory.
    - (SQE) update all positive test cases to include version (if not already there), and add negative test.

Comments
Verified using 7u40-b42
2013-09-09

SQE-OK to get this issue fixed in 7u40.
2013-07-20

pre-verified with 7u40 nightly #33 on Mac 10.7/Safari.
2013-07-20