United StatesChange Country, Oracle Worldwide Web Sites Communities I am a... I want to...
Bug ID: JDK-8007093 build-infra: Make should fail if spec is older than configure files
JDK-8007093 : build-infra: Make should fail if spec is older than configure files

Details
Type:
Bug
Submit Date:
2013-01-29
Status:
Resolved
Updated Date:
2013-02-08
Project Name:
JDK
Resolved Date:
2013-02-04
Component:
infrastructure
OS:
Sub-Component:
build
CPU:
Priority:
P3
Resolution:
Fixed
Affected Versions:
8
Fixed Versions:

Related Reports

Sub Tasks

Description
It's easy to forget to run configure after a pull and it's not obvious if you need to. We should add a make rule that checks if spec.gmk is older than the files in common/autoconf and fail with a helpful error message.
                                    

Comments
URL:   http://hg.openjdk.java.net/jdk8/build/rev/339e4df096a2
User:  erikj
Date:  2013-02-04 14:03:19 +0000

                                     
2013-02-04
URL:   http://hg.openjdk.java.net/jdk8/jdk8/rev/339e4df096a2
User:  katleman
Date:  2013-02-07 01:08:36 +0000

                                     
2013-02-07



Hardware and Software, Engineered to Work Together