Maintenance Notice

The bugs.java.com site will be undergoing maintenance on 15th Dec 2017 21:00 PST to 16th Dec 2017 1:00 AM PST.
JDK-7044316 : DT needs to be aware of new deploy version scheme
  • Type: Bug
  • Component: deploy
  • Sub-Component: deployment_toolkit
  • Affected Version: 7-client
  • Priority: P2
  • Status: Closed
  • Resolution: Fixed
  • OS: windows
  • CPU: x86
  • Submitted: 2011-05-12
  • Updated: 2013-09-12
  • Resolved: 2011-11-28
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availabitlity Release.

To download the current JDK release, click here.
JDK 7 JDK 8
7u2 b03Fixed 8Fixed
Related Reports
Relates :  
Description
DT needs to be aware of new deploy version scheme

e.g isWebStartInstalled simply checks the version based on the installed JRE version - this might not be true anymore - deploy and JRE version is not the same starting in JRE 7.   DT needs update to be aware of this.

Comments
EVALUATION for this CR we are just adding property, "deployVersion" to get the version of the curently registered deploy code
2011-08-11