United StatesChange Country, Oracle Worldwide Web Sites Communities I am a... I want to...
Bug ID: JDK-7019157 errorHandler doesn't compile with super old gcc without precompiled headers
JDK-7019157 : errorHandler doesn't compile with super old gcc without precompiled headers

Details
Type:
Bug
Submit Date:
2011-02-11
Status:
Resolved
Updated Date:
2011-02-26
Project Name:
JDK
Resolved Date:
2011-02-18
Component:
hotspot
OS:
generic
Sub-Component:
build
CPU:
generic
Priority:
P3
Resolution:
Fixed
Affected Versions:
7
Fixed Versions:
hs21 (b02)

Related Reports
Backport:
Relates:
Relates:

Sub Tasks

Description
New errorHandler.hpp source gets error on StackObj.  Need to add
#include "memory/allocation.hpp"

                                    

Comments
EVALUATION

Not restricted to gcc, any build without precompiled headers would fail due to the missing include.
                                     
2011-02-15
EVALUATION

http://hg.openjdk.java.net/jdk7/hotspot-rt/hotspot/rev/7aa1f99ca301
                                     
2011-02-12
EVALUATION

Summary: old gccs don't support precompiled headers so have to supply includes
Reviewed-by: phh, kamg
                                     
2011-02-14



Hardware and Software, Engineered to Work Together