United StatesChange Country, Oracle Worldwide Web Sites Communities I am a... I want to...
Bug ID: JDK-6663557 JRE version selection not working for applets launched via JNLP
JDK-6663557 : JRE version selection not working for applets launched via JNLP

Details
Type:
Bug
Submit Date:
2008-02-15
Status:
Closed
Updated Date:
2010-09-08
Project Name:
JDK
Resolved Date:
2008-06-14
Component:
deploy
OS:
generic,windows
Sub-Component:
plugin
CPU:
generic
Priority:
P2
Resolution:
Fixed
Affected Versions:
6u10
Fixed Versions:
6u10 (b13)

Related Reports
Duplicate:
Relates:
Relates:
Relates:

Sub Tasks

Description
Selection of a JRE version is not working for JNLP-launched applets. The version needs to be extracted from the JNLP file and a determination made whether a relaunch is necessary based on information such as the currently running JRE version and the versions of other installed JREs on the system.

                                    

Comments
SUGGESTED FIX

http://sa.sfbay.sun.com/projects/deployment_data/6u10/6663557.0
                                     
2008-02-15
EVALUATION

Added rudimentary support for JRE version selection in JNLP-launched
applets. Detects if the currently running JRE version does not satisfy
the request in the JNLP file and relaunches the applet specifying
java_version if not. More optimization is possible and will be done in
future putbacks. Auto-download support will also be implemented in a
future putback.

Also included a few minor code cleanups.
                                     
2008-02-15



Hardware and Software, Engineered to Work Together