United StatesChange Country, Oracle Worldwide Web Sites Communities I am a... I want to...
JDK-6331837 : Two Swing DnD methods - rename one and remove another

Details
Type:
Bug
Submit Date:
2005-10-03
Status:
Resolved
Updated Date:
2010-04-02
Project Name:
JDK
Resolved Date:
2005-10-13
Component:
client-libs
OS:
generic
Sub-Component:
javax.swing
CPU:
generic
Priority:
P3
Resolution:
Fixed
Affected Versions:
6
Fixed Versions:

Related Reports
Relates:

Sub Tasks

Description
Two new Swing DnD methods need revision:

TransferHandler.TransferInfo.getDropAction():
    It is unclear what this method will be used for and I believe it could pose a problem when DnD actions are dealt with in a later release. It should be removed.

TransferHandler.shouldIndicateAnyway():
    This method is currently only called to allow the developer to have the component indicate the drop location when canImport() returns false. It makes sense however for the method to also allow them to NOT show the drop location when canImport() is true. It should be renamed to shouldIndicate() and be called for every import.

The new signature should be:
    boolean shouldIndicate(TransferInfo info, canImport boolean)
The canImport boolean will represent the return value from the previous call to canImport() and by default this method should simply return that boolean (to have the drop location indicated only if canImport() is true).

                                    

Comments
EVALUATION

The requested fixes are being made.
                                     
2005-10-03



Hardware and Software, Engineered to Work Together