United StatesChange Country, Oracle Worldwide Web Sites Communities I am a... I want to...
JDK-4952781 : JComponent.get/setPopupMenu() methods must be renamed

Details
Type:
Bug
Submit Date:
2003-11-12
Status:
Resolved
Updated Date:
2004-01-15
Project Name:
JDK
Resolved Date:
2003-12-15
Component:
client-libs
OS:
generic
Sub-Component:
javax.swing
CPU:
generic
Priority:
P1
Resolution:
Fixed
Affected Versions:
5.0
Fixed Versions:
5.0 (b32)

Related Reports
Duplicate:

Sub Tasks

Description

Name: azR10139			Date: 11/12/2003


Implementing CCC request 4634626 several methods has been added
to the JComponent class. But two of them (getPopupMenu and setPopupMenu)
already defined in a child class - JPopupMenu which causes naming conflict.
Visible degradation can be detected in any Swing app with JMenuBar by
right-click on any opened JMenu in JMenuBar. The menu's content will be
shown as separate popup menu.
======================================================================

                                    

Comments
EVALUATION



Name: azR10139			Date: 11/27/2003


Methods will be renamed to setComponentPopupMenu() and getComponentPopupMenu()

###@###.###                11/27/2003
======================================================================
                                     
2003-11-27
CONVERTED DATA

BugTraq+ Release Management Values

COMMIT TO FIX:
tiger-beta

FIXED IN:
tiger-beta

INTEGRATED IN:
tiger-b32
tiger-beta


                                     
2004-08-24



Hardware and Software, Engineered to Work Together