JDK-4616580 : Support for Active-X Bridge
  • Type: Enhancement
  • Status: Resolved
  • Resolution: Fixed
  • Component: deploy
  • Sub-Component: plugin
  • Priority: P3
  • Affected Version:
    bdk_1.0,unknown,1.1.1,1.2.0,1.2.1,1.2.2,1.3.0,1.4.0,5.0 bdk_1.0,unknown,1.1.1,1.2.0,1.2.1,1.2.2,1.3.0,1.4.0,5.0
  • OS:
    generic,windows_95,windows_98,windows_nt,windows_2000,windows_xp generic,windows_95,windows_98,windows_nt,windows_2000,windows_xp
  • CPU: generic,x86
  • Submit Date: 2001-12-20
  • Updated Date: 2002-11-19
  • Resolved Date: 2002-11-19
The Version table provides details related to the release that this issue/RFE will be addressed.

Unresolved : Release in which this issue/RFE will be addressed.
Resolved: Release in which this issue/RFE has been resolved.
Fixed : Release in which this issue/RFE has been fixed. The release containing this fix may be available for download as an Early Access Release or a General Availabitlity Release.

To download the current JDK release, click here.
Other
1.4.2 mantisResolved
Related Reports
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Duplicate :  
Description
Java should support the Active-X Bridge and bean packager technologies.
Originally, the Java Plug-in was based on this support.  However, this is
no longer true in 1.4.  The bridge support was removed to allow development
work to continue on the plugin under a new codebase, and also due to a lack of
customer interest.  Now that the technology has been removed, interest is
growing and we should consider re-implementing the support on a 1.4 codebase
and more fully supporting it.

###@###.### 2001-12-20


Name: nt126004			Date: 02/11/2002


FULL PRODUCT VERSION :
All jdk/jre 1.4 versions

FULL OPERATING SYSTEM VERSION :Windows NT 4.0/2000/XP
use131

A DESCRIPTION OF THE PROBLEM :
Not supporting ActiveX migth be a political decision. But
software developers having their requierements to integrate
with some Microsoft technology, rely on things like the
ActiveX Bridge.
So please reintegrate the ActiveX Bridge into JDK/JRE 1.4
again. It would be very customer friendly.

REGRESSION.  Last worked in version 1.3.1

EXPECTED VERSUS ACTUAL BEHAVIOR :
Working ActiveX Bridge in JDK/JRE 1.4

This bug can be reproduced always.
(Review ID: 139353)
======================================================================

Comments
CONVERTED DATA BugTraq+ Release Management Values COMMIT TO FIX: mantis FIXED IN: mantis INTEGRATED IN: mantis mantis-b08
2004-06-14

PUBLIC COMMENTS The new ActiveX bridge is part of J2RE1.4.2 beta which is released on April 3, 2003. The documentation is available at http://java.sun.com/j2se/1.4.2/docs/guide/beans/axbridge/developerguide/index.html ###@###.### 2003-04-03
2003-04-03

EVALUATION Commit to Tiger. ###@###.### 2002-03-01 committed for mantis ###@###.### 2002-07-30
2002-03-01