This is a request to allow the user to determine to show or hide the
package name as a prefix to class/interface names. Here is one
request to show less, and another to show more:
Is there a way to keep a class from showing up with a fully qualified name?
For example, the method section of one particular javadoc page has 2 methods:
(1) java.lang.String method1()
(2) void method2(java.lang.String s)
It would be much easier to read the documentation if it referred to
String rather than java.lang.String, and
FileInputStream rather than java.io.FileInputStream,
Javadoc currently includes the fully qualified name if the
class is not in the package of the current class.
Details are at:
(This feature may be more important for MIF doclet than the standard doclet,
because printed books are more space conscious than online books.)
Another developer has asked for the opposite -- to display
I'm trying to get javadoc to be package explicit about the "Implemented
Interfaces", "Direct Known Subclasses", "Implements", and the "See Also" list.
Right now with 1.3 (for example) my javadoc html says a class implements
"Destination". I want it to say it implements javax.jms.Destination
It does what I want for things it cannot hyper-link to on the "All Implemented
interfaces" list - eg. java.io.Serializable - I'd like it to do so even for
things it can link to.